Moodle “version 5.5.31 is required and you are running 5.5.5.10.0.X”

I received this error message upgrading an older Moodle installation this weekend to Fedora 21 and Moodle 2.8.2+.

Information on the forums on moodle.org was less than gratifying with little or no work done to explain an answer, merely pontificate about this or that, or my favorite, ask for more information.

Many folks posted less helpful information explaining that a number of 5.5.5.10.0 was indeed lower than 5.5.31 and one needed to upgrade to a newer version of MariaDB.  I believe that is not constructive to a community.

Others posted a link back to the Moodle Bug Report https://tracker.moodle.org/browse/MDL-43604 which is when an earlier and unrelated bug was dealt with.

As always, the answer is intertwined in the method of operations, the question itself, not being snarky about version numbers.

An administrator with an older site, upgrading to a newer site, usually leaves the config.php alone.  After all, how much is in there?  Usually nothing.  But with upgrades to MariaDB version 10.0 and above, one needs to change, per the Moodle documentation (which I skipped), the line regarding what database is being used from MySQL to MariaDB.  That one fix allows the version number to be read quickly and the update to proceed.

I have tried to contribute and answer the posts I found online in the event they are running into the same simple fix I had to make.  Be nice out there, your answer should resolve an issue.

One Reply to “Moodle “version 5.5.31 is required and you are running 5.5.5.10.0.X””

Leave a Reply